<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<title>Review: Action Packed Fury Unleashed is a Great Rogue-Lite with an Emphasis on the &quot;Lite&quot; | Third Coast Review</title>
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://thirdcoastreview.com/xmlrpc.php" />
	<link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet">
	<!--[if lt IE 9]>
	<script src="https://thirdcoastreview.com/wp-content/themes/broadsheet/js/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">var _eab_data={"ajax_url":"https:\/\/thirdcoastreview.com\/wp-admin\/admin-ajax.php","root_url":"https:\/\/thirdcoastreview.com\/wp-content\/plugins\/events-and-bookings\/img\/","fb_scope":"email"};if (!("ontouchstart" in document.documentElement)) document.documentElement.className += " no-touch";</script>
<!-- This site is optimized with the Yoast SEO plugin v8.0 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Review: Action Packed Fury Unleashed is a Great Rogue-Lite with an Emphasis on the &quot;Lite&quot; | Third Coast Review" />
<meta property="og:description" content="Over-the-top is almost like its own subgenre of action. You have games and movies that involve action that take themselves seriously, and then you have those titles that just unapologetically go all &hellip;" />
<meta property="og:url" content="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/" />
<meta property="og:site_name" content="Third Coast Review" />
<meta property="article:publisher" content="http://www.facebook.com/thirdcoastreview" />
<meta property="article:tag" content="Fury Unleashed" />
<meta property="article:tag" content="Patreon" />
<meta property="article:tag" content="Twitch" />
<meta property="article:section" content="Games &amp; Tech" />
<meta property="article:published_time" content="2020-05-18T20:31:22-05:00" />
<meta property="og:image" content="https://thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1-1024x576.jpg" />
<meta property="og:image:secure_url" content="https://thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1-1024x576.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Over-the-top is almost like its own subgenre of action. You have games and movies that involve action that take themselves seriously, and then you have those titles that just unapologetically go all [&hellip;]" />
<meta name="twitter:title" content="Review: Action Packed Fury Unleashed is a Great Rogue-Lite with an Emphasis on the &quot;Lite&quot; | Third Coast Review" />
<meta name="twitter:site" content="@ThirdCoastRvw" />
<meta name="twitter:image" content="https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?fit=2560%2C1440&#038;ssl=1" />
<meta name="twitter:creator" content="@ThirdCoastRvw" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/thirdcoastreview.com\/","sameAs":["http:\/\/www.facebook.com\/thirdcoastreview","https:\/\/www.instagram.com\/thirdcoastreview\/","https:\/\/twitter.com\/ThirdCoastRvw"],"@id":"https:\/\/thirdcoastreview.com\/#organization","name":"Third Coast Review","logo":"https:\/\/thirdcoastreview.com\/wp-content\/uploads\/2016\/08\/LOGO_3rd-Coast-Review.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Third Coast Review &raquo; Feed" href="https://thirdcoastreview.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Third Coast Review &raquo; Comments Feed" href="https://thirdcoastreview.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Third Coast Review &raquo; Review: Action Packed Fury Unleashed is a Great Rogue-Lite with an Emphasis on the &#8220;Lite&#8221; Comments Feed" href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thirdcoastreview.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wphb-critical-css-css'  href='https://thirdcoastreview.com/wp-content/plugins/wp-hummingbird/admin/assets/css/critical.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://thirdcoastreview.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='ssp-frontend-player-css'  href='https://thirdcoastreview.com/wp-content/plugins/seriously-simple-podcasting/assets/css/player.css' type='text/css' media='all' />
<link rel='stylesheet' id='wdsi-css'  href='https://thirdcoastreview.com/wp-content/plugins/slide-in/css/wdsi.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://thirdcoastreview.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_parent-css'  href='https://thirdcoastreview.com/wp-content/themes/broadsheet/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='broadsheet-style-css'  href='https://thirdcoastreview.com/wp-content/themes/broadsheet/styles/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='broadsheet-style-neuton-css'  href='https://fonts.googleapis.com/css?family=Neuton%3A400%2C700&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='eab-upcoming_calendar_widget-style-css'  href='https://thirdcoastreview.com/wp-content/plugins/events-and-bookings/css/upcoming_calendar_widget.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://thirdcoastreview.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-wpmu-ui-3-min-css-css'  href='https://thirdcoastreview.com/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/css/wpmu-ui.3.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpmu-animate-3-min-css-css'  href='https://thirdcoastreview.com/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/css/animate.3.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_child-css'  href='https://thirdcoastreview.com/wp-content/themes/broadsheet-child/style.css' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://thirdcoastreview.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://thirdcoastreview.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://thirdcoastreview.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wdsi_data = {"reshow":{"timeout":0,"name":"wdsi-on_hided41d8cd98f00b204e9800998ecf8427e","path":"\/","all":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/slide-in/js/wdsi.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-includes/js/masonry.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var js_i18n = {"next":"next","prev":"previous","menu":"Menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/themes/broadsheet/js/main.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/themes/broadsheet/js/responsiveNavigation.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/events-and-bookings/js/upcoming_calendar_widget.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js'></script>
<link rel='https://api.w.org/' href='https://thirdcoastreview.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thirdcoastreview.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thirdcoastreview.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.1.5" />
<meta name="generator" content="Seriously Simple Podcasting 1.19.11" />
<link rel='shortlink' href='https://wp.me/p744EU-iEj' />
<link rel="alternate" type="application/json+oembed" href="https://thirdcoastreview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthirdcoastreview.com%2F2020%2F05%2F18%2Freview-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thirdcoastreview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthirdcoastreview.com%2F2020%2F05%2F18%2Freview-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite%2F&#038;format=xml" />

            <script>
                (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
                })(window,document,'script','//www.google-analytics.com/analytics.js','gaplusu');

                function gaplus_track() {
                                                gaplusu('create', 'UA-70338558-5', 'auto');
                                                                                                    gaplusu('send', 'pageview');
                    
                                    }

                                    gaplus_track();
                
            </script>

		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-70338558-5"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-70338558-5');
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-97558892-1', 'auto');
  ga('send', 'pageview');

</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://thirdcoastreview.com/feed/podcast" />

<script type="text/javascript">if ( window._agmMaps === undefined ) { _agmMaps = []; }</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style>
	.masthead .branding h1.logo a,
	.masthead .branding h1.logo a:hover,
	.masthead .branding h2.description {
		color:#000000;
	}
</style>
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-71691 single-format-standard singular themes-sidebar1-active themes-sidebar2-active themes-sidebar3-active themes-category-summaries-active themes-has-featured-posts has-site-logo">

<div class="container hfeed">
	<header class="masthead" role="banner">
				<div class="branding">
			<h1 class="logo">
				<a href="https://thirdcoastreview.com/" class="site-logo-link" rel="home" itemprop="url">

<img src="https://thirdcoastreview.com/wp-content/uploads/2016/01/LOGO_3rd-Coast-Review.png" class="site-logo attachment-broadsheet-attachment" alt="LOGO_3rd Coast Review" data-size="broadsheet-attachment" itemprop="logo" scale="2">

				</a>
			</h1>
			<h2 class="description">
				Chicago Arts and Culture, Curated			</h2>
			<p class="postmetadata">
Tuesday, May 19th, 2020			</p>
		</div>
		<form method="get" class="searchform" action="https://thirdcoastreview.com/" role="search">
	<label>
		<span class="screen-reader">Search for...</span>
		<input type="search" value="" name="s" class="searchfield text" placeholder="Search..." />
	</label>
	<button class="searchsubmit">&#62464;</button>
</form>	</header>
	<!-- 3CR top banner -->
	<div style="text-align: center;">
	<ins class="adsbygoogle"
		 style="display:inline-block;width:728px;height:90px"
		 data-ad-client="ca-pub-1592383647630474"
		 data-ad-slot="6885689006"></ins>
	<script>
		 (adsbygoogle = window.adsbygoogle || []).push({});
	</script>
	</div>
			<a href="https://thirdcoastreview.com/" title="Third Coast Review" rel="home" class="header-image">
			<img src="https://thirdcoastreview.com/wp-content/uploads/2019/02/cropped-3cr-banner-AaronCynic-Riversunset02.jpg" width="1140" height="401" alt="" />
		</a>
	<nav class="menu-primary" role="navigation">
		<div class="menu">
			<div class="menu-menu-1-container"><ul id="nav" class="menu-wrap clearfix"><li id="menu-item-34563" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34563"><a href="https://thirdcoastreview.com/category/today/">Today</a></li>
<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168"><a href="https://thirdcoastreview.com/category/stages/">Stages</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41"><a href="https://thirdcoastreview.com/category/screens/">Screens</a></li>
<li id="menu-item-22121" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22121"><a href="https://thirdcoastreview.com/category/games-tech/">Games &#038; Tech</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://thirdcoastreview.com/category/art/">Art &amp; Museums</a></li>
<li id="menu-item-42" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-42"><a href="https://thirdcoastreview.com/category/music/">Music</a>
<ul class="sub-menu">
	<li id="menu-item-7565" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7565"><a href="https://thirdcoastreview.com/category/audio/">Audio</a></li>
</ul>
</li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43"><a href="https://thirdcoastreview.com/category/lit/">Lit</a></li>
<li id="menu-item-44" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44"><a href="https://thirdcoastreview.com/category/food/">Food</a></li>
<li id="menu-item-836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-836"><a href="https://thirdcoastreview.com/category/beyond/">Beyond</a>
<ul class="sub-menu">
	<li id="menu-item-20973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20973"><a href="https://thirdcoastreview.com/category/beyond/miscellaneous-rants/">Soapbox</a></li>
</ul>
</li>
<li id="menu-item-45" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-45"><a href="https://thirdcoastreview.com/about/">About Us</a>
<ul class="sub-menu">
	<li id="menu-item-169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-169"><a href="https://thirdcoastreview.com/about/contributors/">Our Writers</a></li>
</ul>
</li>
</ul></div>		</div>
	</nav>

	<div class="main"><div class="col-sidebar sidebar-small" role="complementary">
<section id="linkcat-20" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle">Sites We Like</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://arcchicago.blogspot.com/" title="Architecture blog">Architecture Chicago Plus</a></li>
<li><a href="http://www.brooklynvegan.com/chicago/" title="Music news, live events, pictures and reviews of Chicago shows.">Brooklyn Vegan Chicago</a></li>
<li><a href="http://chicagoliterati.com/" title="Chicago&#8217;s online literary magazine">Chicago Literati</a></li>
<li><a href="http://chirpradio.org/" title="Sounds and conversations with musical Chicagoans.">Chirp Radio</a></li>
<li><a href="http://do312.com/" title="What to do in Chicago">DO312</a></li>
<li><a href="http://www.wbez.org/blogs/jim-derogatis" title="Pop music blog by Chicago music writer">Jim DeRogatis</a></li>
<li><a href="http://loudlooppress.com/">Loud Loop Press</a></li>
<li><a href="http://missmodernist.com/" title="The Paris Review Blog, among other lit matters">Miss Modernist</a></li>
<li><a href="http://popstache.com/" title="We get off on music. We do what we like and we like what we do.">Pop &#039;stache</a></li>
<li><a href="http://www.popmatters.com/" title="National pop culture site: music, movies, TV, books, comics, etc.">Pop Matters</a></li>
<li><a href="http://www.theminimalbeat.com/" title="A daily journal of music.">The Minimal Beat</a></li>
<li><a href="http://www.chicagotribune.com/entertainment/theater/" title="Chris Jones&#8217; Tribune theater column">Theater Loop</a></li>
<li><a href="http://www.theatreinchicago.com/" title="Compilation site for Chicago theater reviews">Theatre In Chicago</a></li>
<li><a href="http://vamstudio.net/" title="The best of underground art in all media.  ">VAM Magazine</a></li>
<li><a href="http://whitecitycinema.com/" title="Michael Glover Smith&#8217;s film blog">White City Cinema</a></li>
<li><a href="http://wonderfulcinema.com/" title="Reviews of a wide range of films, many cult and foreign classics">Wonderful Cinema</a></li>

	</ul>
</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h3 class="widgettitle">Recent Posts</h3>		<ul>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/">Review: Action Packed <em>Fury Unleashed</em> is a Great Rogue-Lite with an Emphasis on the &#8220;Lite&#8221;</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/18/book-review-banned-book-club-by-kim-hyun-sook-ko-hyung-ju-and-ryan-e/">Book Review—<Em>Banned Book Club</em>—By Kim Hyun Sook, et alia</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/18/sunday-storms-cause-major-flooding-close-lower-wacker-and-knock-out-power-at-willis-tower/">Sunday Storms Cause Major Flooding, Close Lower Wacker, and Knock Out Power at Willis Tower</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/18/they-call-me-disco-is-the-danceable-magical-sonic-wonderland-we-all-needed-right-now/"><em>They Call Me Disco</em> is the Danceable, Magical Sonic Wonderland We all Needed Right Now</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/16/review-food-politics-and-the-joy-of-shallots-return-in-timelines-to-master-the-art/">Review: Food, Politics, and the Joy of Shallots Return in Timeline’s <em>To Master the Art</em></a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/15/review-pride-live-reading-series-features-steven-dietz-lonely-planet-a-play-about-chairs/">Review: Pride Live Reading Series Features Steven Dietz’ <em>Lonely Planet</em>, a Play About Chairs</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/15/film-review-scoob/">Review: Animated, Direct-to-VOD <em>Scoob!</em> Is Somehow Too Much and Not Enough</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/15/film-review-alice-2020/">Review: <em>Alice</em> Proves a Promising if Over-Polished Debut Feature Film</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/15/film-review-fourteen/">Review: Slight <em>Fourteen</em> Considers Friendship Over the Years</a>
									</li>
											<li>
					<a href="https://thirdcoastreview.com/2020/05/15/film-review-up-from-the-streets/">Review: <em>Up From the Streets</em> is New Orlean&#8217;s Massive Music History in One Heartfelt Documentary</a>
									</li>
					</ul>
		</div></section><section id="adlitewidget-4" class="widget adlitewidget"><div class="widget-wrap"><div class="textwidget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1592383647630474"
     data-ad-slot="5233534285"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></section></div>
	<div class="main-content">
<article id="post-71691" class="post-71691 post type-post status-publish format-standard has-post-thumbnail hentry category-game-games-tech category-games-tech category-review-games-tech tag-fury-unleashed tag-patreon tag-twitch">
<a href="https://thirdcoastreview.com/category/games-tech/game-games-tech/" class="post-lead-category">Game</a>
<h1 class="title">Review: Action Packed <em>Fury Unleashed</em> is a Great Rogue-Lite with an Emphasis on the &#8220;Lite&#8221;</h1>	<div class="postmetadata">
<span class="text-by">By</span> <span class="author vcard"><a class="url fn n" href="https://thirdcoastreview.com/author/antalbokor/" title="View all posts by Antal Bokor" rel="author">Antal Bokor</a></span> <span class="text-on">on</span> <a href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/" title="8:31 pm" rel="bookmark"><time class="entry-date" datetime="2020-05-18T20:31:22-05:00">May 18, 2020</time></a>	&bull; <span class="commentcount">( <a href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/#respond">Leave a comment</a> )</span>
	</div>	<section class="entry">
<div id="attachment_71719" style="width: 649px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-71719" data-attachment-id="71719" data-permalink="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/20200515181950_1/" data-orig-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20200515181950_1" data-image-description="" data-medium-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?fit=639%2C359&amp;ssl=1" class="size-large wp-image-71719" src="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?resize=639%2C359&#038;ssl=1" alt="" width="639" height="359" srcset="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?w=1278&amp;ssl=1 1278w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181950_1.jpg?w=1917&amp;ssl=1 1917w" sizes="(max-width: 639px) 100vw, 639px" data-recalc-dims="1" /><p id="caption-attachment-71719" class="wp-caption-text">Screenshot: Fury Unleashed</p></div>
<p><img data-attachment-id="40547" data-permalink="https://thirdcoastreview.com/2018/11/06/new-york-review-vonneguts-happy-birthday-wanda-june/3-star-rating/" data-orig-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2018/11/3-Star-Rating.png?fit=150%2C67&amp;ssl=1" data-orig-size="150,67" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="3 Star Rating" data-image-description="" data-medium-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2018/11/3-Star-Rating.png?fit=150%2C67&amp;ssl=1" data-large-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2018/11/3-Star-Rating.png?fit=150%2C67&amp;ssl=1" class="alignright size-full wp-image-40547" src="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2018/11/3-Star-Rating.png?resize=150%2C67&#038;ssl=1" alt="" width="150" height="67" data-recalc-dims="1" />Over-the-top is almost like its own subgenre of action. You have games and movies that involve action that take themselves seriously, and then you have those titles that just unapologetically go all out. My first impression upon seeing <em>Fury Unleashed</em> was that it would be a combination of <em>Broforce</em> and <em>Metal Slug</em>—and it kind of is. With its comic theme and rogue-lite elements, it’s something I haven’t quite played before—and it’s damn fun, too.</p><div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1592383647630474"
     data-ad-slot="5233534285"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<p><em>Fury Unleashed</em> is a side scrolling action game with rogue-lite elements, and roleplaying game character progression. You play as Fury—or a multitude of other unlockable characters—as he fights his way through three issues of the comic book series in which he’s the titular protagonist. Each comic is made up of a few sections which represented by pages in a comic book, with the rooms cleverly being the panels that make up the comic pages. Each playthrough is randomized—with different room locations, mini-bosses, end bosses, and enemy types and placement. Each of the three comics are themed, too—with different enemies and hazards in each. And there’s an overarching narrative that ties it all together—but it’s about the comic creator, not the action you’re seeing on screen.</p>
<div id="attachment_71716" style="width: 649px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-71716" data-attachment-id="71716" data-permalink="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/20200514193125_1/" data-orig-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20200514193125_1" data-image-description="" data-medium-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?fit=639%2C359&amp;ssl=1" class="size-large wp-image-71716" src="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?resize=639%2C359&#038;ssl=1" alt="" width="639" height="359" srcset="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?w=1278&amp;ssl=1 1278w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514193125_1.jpg?w=1917&amp;ssl=1 1917w" sizes="(max-width: 639px) 100vw, 639px" data-recalc-dims="1" /><p id="caption-attachment-71716" class="wp-caption-text">Screenshot: Fury Unleashed</p></div>
<p>There is a story underneath the action of <em>Fury Unleashed</em>—but it’s really not something I expected. It’s actually about the creator of the <em>Fury</em> comics, and deals with the issues the creator is going through. The story is told through interactions with Mr. Doodle, who is apparently telling the story. These interactions usually lead to short, black and white interstitials—pencil sketched rooms that feature conversations, bad reviews, and other interaction with the mysterious creator. But truthfully, these narrative interstitials are easy to ignore to get back to the great gunplay.</p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1592383647630474"
     data-ad-slot="5233534285"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<p>The gameplay in <em>Fury Unleashed</em> is fun. Shooting is satisfying, and the movement is done excellently. Dashing away from enemy projectiles and returning fire is responsive&#8211;and addictive. If you’re above an enemy, you can stomp on their head to dispatch them, and there are multiple grenade types to play around with. Aiming and moving works almost like a twin-stick shooter, with movement and shooting independent—which is good, because there are often so many enemy projectiles, <em>Fury Unleashed</em> resides in one of the circles of bullet hell. On top of all of that, there’s a combo system to juggle—with the higher combos giving you chances at important health pick-ups. The higher your combo, the more the music ramps up too, driving you forward to maintain those big numbers.</p>
<div id="attachment_71707" style="width: 649px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-71707" data-attachment-id="71707" data-permalink="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/20200512180626_1/" data-orig-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20200512180626_1" data-image-description="" data-medium-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?fit=639%2C359&amp;ssl=1" class="size-large wp-image-71707" src="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?resize=639%2C359&#038;ssl=1" alt="" width="639" height="359" srcset="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?w=1278&amp;ssl=1 1278w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200512180626_1.jpg?w=1917&amp;ssl=1 1917w" sizes="(max-width: 639px) 100vw, 639px" data-recalc-dims="1" /><p id="caption-attachment-71707" class="wp-caption-text">Screenshot: Fury Unleashed</p></div>
<p>The weapon selection in <em>Fury Unleashed </em>is great, too. Most of the guns are just plain fun to use. And even if you don’t like any particular weapon, it’s possible you can get a better version of that weapon eventually. If your rocket launcher fires too slowly, you might find one with more damage that fires multiple rockets at once. There are some weapons I didn’t care much for, but then I found a variant that made me swear it was the most fun I’ve had in the game. There are different melee weapons to find, too, but I found that they altered gameplay even less—though the different grenade variants are great.</p>
<p><em>Fury Unleashed</em> wouldn’t be very fun if it didn’t have interesting enemies, but it does. Each comic has a different theme, and a different set of enemies to go along with it. There are skeletons and Nazis and Aliens (oh my) to contend with across the three comics. The boss encounters are similarly exciting, and interesting, with their own (often) bullet hell like attacks to dodge through.</p>
<div id="attachment_71712" style="width: 649px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-71712" data-attachment-id="71712" data-permalink="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/20200514182236_1/" data-orig-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20200514182236_1" data-image-description="" data-medium-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?fit=639%2C359&amp;ssl=1" class="size-large wp-image-71712" src="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?resize=639%2C359&#038;ssl=1" alt="" width="639" height="359" srcset="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?w=1278&amp;ssl=1 1278w, https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200514182236_1.jpg?w=1917&amp;ssl=1 1917w" sizes="(max-width: 639px) 100vw, 639px" data-recalc-dims="1" /><p id="caption-attachment-71712" class="wp-caption-text">Screenshot: Fury Unleashed</p></div>
<p>As fun as <em>Fury Unleashed</em> is, I feel like there’s almost one too many systems you have to juggle. Dashing, shooting, jumping, throwing grenades, stomping, and keeping up your combo can feel a little overwhelming at first. But it is a rogue-lite game, and in such games, success isn’t guaranteed. In fact, it’s expected that you will die, pick up incremental advantages, and most likely die time and again before seeing all the game has to offer. <em>Fury Unleashed</em> is no different, and once it clicks, it clicks. Still, <em>Fury Unleashed</em> is definitely more on the “lite” side of the “<em>Rogue</em>” spectrum.</p>
<p>I appreciate always-forward progression in any game, and with the different weapon types to unlock, and the skill tree, progression is certainly always forward in <em>Fury Unleashed</em>. While death ends your run in <em>Fury Unleashed, </em>like it would in any title, it’s not really “permadeath.” Instead, you lose whatever money, armor, weapons, and grenades you’re in possession of—but whatever ink you collected during a run goes toward increasing your character’s permanent level. The entire skill tree stays active, even after death, so it’s possible to eventually fill it up and unleash your true Fury. What’s even better is that after defeating three of the end bosses for a comic, it allows you to completely skip over that comic—something that is rare in any rogue-lite.</p>
<div id="attachment_71718" style="width: 649px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-71718" data-attachment-id="71718" data-permalink="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/20200515181942_1/" data-orig-file="https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20200515181942_1" data-image-description="" data-medium-file="https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?fit=639%2C359&amp;ssl=1" class="size-large wp-image-71718" src="https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?resize=639%2C359&#038;ssl=1" alt="" width="639" height="359" srcset="https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?w=1278&amp;ssl=1 1278w, https://i0.wp.com/thirdcoastreview.com/wp-content/uploads/2020/05/20200515181942_1.jpg?w=1917&amp;ssl=1 1917w" sizes="(max-width: 639px) 100vw, 639px" data-recalc-dims="1" /><p id="caption-attachment-71718" class="wp-caption-text">Screenshot: Fury Unleashed</p></div>
<p>If you get lonely blasting things as Fury (or the other characters you can choose from) you can always invite a friend to play. The co-op is local only, and shared screen—making it feel like an old-school title. I’d love some online multiplayer, but nothing quite matches the feeling of couch co-op.</p>
<p>I really enjoyed <em>Fury Unleashed</em>. It’s got explosive action, a great set of guns, and it’s so light on the “<em>Rogue” </em>that it feels more like an action roleplaying game at times. It can be a little overwhelming to juggle all of the mechanics at first, but dying and learning is part of the formula. I definitely recommend <em>Fury Unleashed</em>.</p>
<p>&nbsp;</p>
<p><em>Fury Unleashed</em> is available now on Nintendo Switch, Xbox One, PlayStation 4, and Windows</p>
<p>&nbsp;</p>
<p><em>The Games and Tech section is looking for writers. If you have a passion for video games, tabletop roleplaying games, board games, or consumer technology, contact our Games &amp; Tech Editor at  antal@thirdcoastreview.com. Previous writing experience is preferred but not required. You can also catch us streaming games for review (and some of our favorite titles) on Twitch at <a href="http://www.twitch.tv/bokor">www.twitch.tv/bokor</a>. </em></p>
<p><em>If you like what we’re doing, consider supporting at <a href="http://Patreon.com/3CR">Patreon.com/3CR</a></em></p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-71691" class="share-twitter sd-button share-icon no-text" href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/?share=twitter" rel="noopener noreferrer" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-71691" class="share-facebook sd-button share-icon no-text" href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/?share=facebook" rel="noopener noreferrer" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-71691" class="share-google-plus-1 sd-button share-icon no-text" href="https://thirdcoastreview.com/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/?share=google-plus-1" rel="noopener noreferrer" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>		<div class="taxonomies">
			<p class="tax-categories taxonomy">Categories: <a href="https://thirdcoastreview.com/category/games-tech/game-games-tech/" rel="tag">Game</a>, <a href="https://thirdcoastreview.com/category/games-tech/" rel="tag">Games &amp; Tech</a>, <a href="https://thirdcoastreview.com/category/games-tech/review-games-tech/" rel="tag">Review</a>			</p>
<p class="tax-tags taxonomy">Tagged as: <a href="https://thirdcoastreview.com/tag/fury-unleashed/" rel="tag">Fury Unleashed</a>, <a href="https://thirdcoastreview.com/tag/patreon/" rel="tag">Patreon</a>, <a href="https://thirdcoastreview.com/tag/twitch/" rel="tag">Twitch</a></p>		</div>	</section>
</article>
<nav class="postnav">
	<h1 class="screen-reader">Post navigation</h1>
	<div class="prev">
		<span class="more-link"><a href="https://thirdcoastreview.com/2020/05/18/book-review-banned-book-club-by-kim-hyun-sook-ko-hyung-ju-and-ryan-e/" rel="prev">Book Review—<Em>Banned Book Club</em>—By Kim Hyun Sook, et alia</a></span>	</div>
	<div class="next">
			</div>
</nav><section class="content-comments">
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/05/18/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://thirdcoastreview.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='71691' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1f08714392" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="97"/></p>			</form>
			</div><!-- #respond -->
	</section>	</div>
	</div>
<div class="col-sidebar sidebar-main" role="complementary">
<section id="text-6" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle">Support us on Patreon</h3>			<div class="textwidget"><p><a href="https://www.patreon.com/3CR" target="_blank" rel="noopener"><img class="aligncenter wp-image-28033 size-medium" src="https://i2.wp.com/thirdcoastreview.com/wp-content/uploads/2018/05/3cr-patreon_logomark_color_on_coral@2x-1.png?resize=300%2C300&#038;ssl=1" alt="" width="300" height="300" data-recalc-dims="1" /></a></p>
<h3 style="text-align: center;"><a href="https://www.patreon.com/3CR" target="_blank" rel="noopener">Become a Patron</a></h3>
</div>
		</div></section><section id="incsub_event_upcoming-2" class="widget widget_incsub_event_upcoming"><div class="widget-wrap"><h3 class="widgettitle">3CR&#8217;s Favorite Events</h3><div id="event-popular"><ul class="eventList"><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-19T19:00:00-0500'><var class="eab-date_format-date">May 19, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">7:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-19T23:59:00-0500'></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-19T19:00:00-0500'><var class="eab-date_format-date">May 19, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">7:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-19T23:59:00-0500'></time></div><a href="https://thirdcoastreview.com/events/2020/05/the-hideout-online-the-interview-show-twitch-on-your-favorite-streaming-device/" class="" >The Hideout Online: The Interview Show @ Twitch on your favorite streaming device</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-20T18:00:00-0500'><var class="eab-date_format-date">May 20, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">6:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-20T18:30:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:30 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-20T18:00:00-0500'><var class="eab-date_format-date">May 20, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">6:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-20T18:30:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:30 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-2-2/" class="" >At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-20T19:00:00-0500'><var class="eab-date_format-date">May 20, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">7:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-20T21:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">9:00 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-20T19:00:00-0500'><var class="eab-date_format-date">May 20, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">7:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-20T21:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">9:00 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/the-hideout-online-twitch-on-your-favorite-streaming-device-2/" class="" >The Hideout Online: Veggie Bingo @ Twitch on your favorite streaming device</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-21T19:00:00-0500'><var class="eab-date_format-date">May 21, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">7:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-21T22:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">10:00 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-21T19:00:00-0500'><var class="eab-date_format-date">May 21, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">7:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-21T22:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">10:00 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/the-quarantine-concerts-experimental-sound-studios-twitch-16/" class="" >The Quarantine Concerts @ Experimental Sound Studios Twitch</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-22T17:00:00-0500'><var class="eab-date_format-date">May 22, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">5:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-22T19:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">7:00 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-22T17:00:00-0500'><var class="eab-date_format-date">May 22, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">5:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-22T19:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">7:00 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/the-hideout-online-lp-happy-hour-twitch-on-your-favorite-streaming-device-2/" class="" >The Hideout Online: LP Happy Hour @ Twitch on your favorite streaming device</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-23T12:00:00-0500'><var class="eab-date_format-date">May 23, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">12:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-23T13:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">1:00 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-23T12:00:00-0500'><var class="eab-date_format-date">May 23, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">12:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-23T13:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">1:00 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/goose-island-beer-yoga-the-goose-island-cybourn-brewhouse-instagram-live-2/" class="" >Goose Island Beer Yoga @ the Goose Island Cybourn Brewhouse Instagram Live</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-23T16:00:00-0500'><var class="eab-date_format-date">May 23, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">4:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-23T18:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:00 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-23T16:00:00-0500'><var class="eab-date_format-date">May 23, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">4:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-23T18:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:00 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/fitzgeralds-stay-at-home-concert-series-their-facebook-page-2/" class="" >FitzGerald’s Stay-At-Home Concert Series with Toronzo Cannon@ Their Facebook Page,</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-24T18:00:00-0500'><var class="eab-date_format-date">May 24, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">6:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-24T18:30:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:30 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-24T18:00:00-0500'><var class="eab-date_format-date">May 24, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">6:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-24T18:30:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:30 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-3/" class="" >At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-27T18:00:00-0500'><var class="eab-date_format-date">May 27, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">6:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-27T18:30:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:30 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-27T18:00:00-0500'><var class="eab-date_format-date">May 27, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">6:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-27T18:30:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">6:30 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-3-2/" class="" >At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,</a></li><li><div class="wpmudevevents-date"><time itemprop='startDate' datetime='2020-05-30T12:00:00-0500'><var class="eab-date_format-date">May 30, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">12:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-30T13:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">1:00 pm</var></span></span><br /></time></div><div class="wpmudevevents-date1"><time itemprop='startDate' datetime='2020-05-30T12:00:00-0500'><var class="eab-date_format-date">May 30, 2020</var> <span class="wpmudevevents-date_format-start">from <var class="eab-date_format-time">12:00 pm</var></span></time> <time itemprop='endDate' datetime='2020-05-30T13:00:00-0500'><span class="wpmudevevents-date_format-end">to <span class="wpmudevevents-date_format-end_date"><var class="eab-date_format-date"></var></span> <span class="wpmudevevents-date_format-end_time"><var class="eab-date_format-time">1:00 pm</var></span></span><br /></time></div><a href="https://thirdcoastreview.com/events/2020/05/goose-island-beer-yoga-the-goose-island-cybourn-brewhouse-instagram-live-3/" class="" >Goose Island Beer Yoga @ the Goose Island Cybourn Brewhouse Instagram Live</a></li></ul></div></div></section><section id="eab_calendarupcoming_widget-2" class="widget Eab_CalendarUpcoming_Widget"><div class="widget-wrap"><div data-eab-widget_id="2"><table width='100%'  class='eab-upcoming_calendar_widget'><thead><tr><th>Su</th><th>Mo</th><th>Tu</th><th>We</th><th>Th</th><th>Fr</th><th>Sa</th></tr></thead><tbody><tr><td class="no-left-border" colspan="5">&nbsp;</td><td ><p>1</p></td><td ><p>2</p></td></tr><tr><td ><p>3</p></td><td ><p>4</p></td><td ><p>5</p></td><td ><p>6</p></td><td ><p>7</p></td><td ><p>8</p></td><td ><p>9</p></td></tr><tr><td ><p>10</p></td><td ><p>11</p></td><td ><p>12</p></td><td ><p>13</p></td><td ><p>14</p></td><td ><p>15</p></td><td ><p>16</p></td></tr><tr><td ><p>17</p></td><td ><p>18</p></td><td class="eab-has_events today"><p><a href='#' title='The Hideout Online: The Interview Show @ Twitch on your favorite streaming device'>19</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/the-hideout-online-the-interview-show-twitch-on-your-favorite-streaming-device/">The Hideout Online: The Interview Show @ Twitch on your favorite streaming device<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-19T19:00:00-0500"><var class="eab-date_format-date">May 19, 2020</var></time> </span></a></span></p></td><td class="eab-has_events"><p><a href='#' title='At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,, The Hideout Online: Veggie Bingo @ Twitch on your favorite streaming device'>20</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-2-2/">At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-20T18:00:00-0500"><var class="eab-date_format-date">May 20, 2020</var></time> </span></a><br /><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/the-hideout-online-twitch-on-your-favorite-streaming-device-2/">The Hideout Online: Veggie Bingo @ Twitch on your favorite streaming device<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-20T19:00:00-0500"><var class="eab-date_format-date">May 20, 2020</var></time> </span></a></span></p></td><td class="eab-has_events"><p><a href='#' title='The Quarantine Concerts @ Experimental Sound Studios Twitch'>21</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/the-quarantine-concerts-experimental-sound-studios-twitch-16/">The Quarantine Concerts @ Experimental Sound Studios Twitch<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-21T19:00:00-0500"><var class="eab-date_format-date">May 21, 2020</var></time> </span></a></span></p></td><td class="eab-has_events"><p><a href='#' title='The Hideout Online: LP Happy Hour @ Twitch on your favorite streaming device'>22</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/the-hideout-online-lp-happy-hour-twitch-on-your-favorite-streaming-device-2/">The Hideout Online: LP Happy Hour @ Twitch on your favorite streaming device<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-22T17:00:00-0500"><var class="eab-date_format-date">May 22, 2020</var></time> </span></a></span></p></td><td class="eab-has_events"><p><a href='#' title='Goose Island Beer Yoga @ the Goose Island Cybourn Brewhouse Instagram Live, FitzGerald’s Stay-At-Home Concert Series with Toronzo Cannon@ Their Facebook Page,'>23</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/goose-island-beer-yoga-the-goose-island-cybourn-brewhouse-instagram-live-2/">Goose Island Beer Yoga @ the Goose Island Cybourn Brewhouse Instagram Live<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-23T12:00:00-0500"><var class="eab-date_format-date">May 23, 2020</var></time> </span></a><br /><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/fitzgeralds-stay-at-home-concert-series-their-facebook-page-2/">FitzGerald’s Stay-At-Home Concert Series with Toronzo Cannon@ Their Facebook Page,<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-23T16:00:00-0500"><var class="eab-date_format-date">May 23, 2020</var></time> </span></a></span></p></td></tr><tr><td class="eab-has_events"><p><a href='#' title='At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,'>24</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-3/">At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-24T18:00:00-0500"><var class="eab-date_format-date">May 24, 2020</var></time> </span></a></span></p></td><td ><p>25</p></td><td ><p>26</p></td><td class="eab-has_events"><p><a href='#' title='At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,'>27</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-3-2/">At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-27T18:00:00-0500"><var class="eab-date_format-date">May 27, 2020</var></time> </span></a></span></p></td><td ><p>28</p></td><td ><p>29</p></td><td class="eab-has_events"><p><a href='#' title='Goose Island Beer Yoga @ the Goose Island Cybourn Brewhouse Instagram Live, FitzGerald’s Stay-At-Home Concert Series with Ryan Joseph Anderson@ Their Facebook Page,'>30</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/goose-island-beer-yoga-the-goose-island-cybourn-brewhouse-instagram-live-3/">Goose Island Beer Yoga @ the Goose Island Cybourn Brewhouse Instagram Live<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-30T12:00:00-0500"><var class="eab-date_format-date">May 30, 2020</var></time> </span></a><br /><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/fitzgeralds-stay-at-home-concert-series-their-facebook-page-3/">FitzGerald’s Stay-At-Home Concert Series with Ryan Joseph Anderson@ Their Facebook Page,<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-30T16:00:00-0500"><var class="eab-date_format-date">May 30, 2020</var></time> </span></a></span></p></td></tr><tr><td class="eab-has_events"><p><a href='#' title='At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,'>31</a><span class='wdpmudevevents-upcoming_calendar_widget-info_wrapper' style='display:none'><a class="wpmudevevents-upcoming_calendar_widget-event open" href="https://thirdcoastreview.com/events/2020/05/at-home-with-the-auditorium-the-auditorium-theatre-facebook-and-instagram-4/">At Home with the Auditorium @ The Auditorium Theatre Facebook and Instagram,<span class="wpmudevevents-upcoming_calendar_widget-event-info"><time datetime="2020-05-31T18:00:00-0500"><var class="eab-date_format-date">May 31, 2020</var></time> </span></a></span></p></td><td class="no-right-border" colspan="6">&nbsp;</td></tr><tr><td><a class="eab-upcoming_calendar_widget-navigation-link eab-navigation-next eab-time_unit-year" href="https://thirdcoastreview.com/events/2019/05/">&nbsp;&laquo;</a></td><td><a class="eab-upcoming_calendar_widget-navigation-link eab-navigation-next eab-time_unit-month" href="https://thirdcoastreview.com/events/2020/04/">&nbsp;&lsaquo;</a></td><td colspan="3" style="text-align:center;"><input type="hidden" class="eab-cuw-calendar_date" value="1589849812" /><a href="https://thirdcoastreview.com/events/2020/05/" class="eab-upcoming_calendar_widget-navigation-link eab-cuw-calendar_date">May 2020</a></td><td><a class="eab-upcoming_calendar_widget-navigation-link eab-navigation-prev eab-time_unit-month" href="https://thirdcoastreview.com/events/2020/06/">&rsaquo;&nbsp;</a></td><td><a class="eab-upcoming_calendar_widget-navigation-link eab-navigation-prev eab-time_unit-year" href="https://thirdcoastreview.com/events/2021/05/">&raquo;&nbsp;</a></td></tr></tbody></table></div></div></section><section id="adlitewidget-3" class="widget adlitewidget"><div class="widget-wrap"><div class="textwidget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1592383647630474"
     data-ad-slot="5233534285"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></section><section id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div id="slideIn"></div></div>
		</div></section></div>
</div>

<footer role="contentinfo" id="footer" class="container">
	<aside class="footer-widgets sidebar-footer">
		<section id="wpcom_social_media_icons_widget-3" class="widget widget_wpcom_social_media_icons_widget"><div class="widget-wrap"><h3 class="widgettitle">Social</h3><ul><li><a href="https://www.facebook.com/thirdcoastreview/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View thirdcoastreview&#8217;s profile on Facebook</span></a></li><li><a href="https://twitter.com/@ThirdCoastRvw/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View @ThirdCoastRvw&#8217;s profile on Twitter</span></a></li><li><a href="https://www.instagram.com/thirdcoastreview/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View thirdcoastreview&#8217;s profile on Instagram</span></a></li></ul></div></section><section id="text-4" class="widget widget_text"><div class="widget-wrap"><h3 class="widgettitle">Contact us</h3>			<div class="textwidget"><p><a href="/contact/">Click here to go to our contact form.</a></p>
<p>Or email us <a href="mailto:info@thirdcoastreview.com">here.</a></p>
</div>
		</div></section>	</aside>
	<section class="footer-wrap">
				<ul>
			<li><strong>Top categories: </strong> <a href="https://thirdcoastreview.com/category/screens/">Screens</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/screens/film/">Film</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/music/">Music</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/screens/review/">Review</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/stages/">Stages</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/stages/theater/">Theater</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/music/reviews/">Reviews</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/games-tech/">Games &amp; Tech</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/today/">Today</a><span class="sep">/</span><a href="https://thirdcoastreview.com/category/games-tech/game-games-tech/">Game</a></li><li><strong>Top tags: </strong>  <a href="https://thirdcoastreview.com/tag/chicago/">Chicago</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/steam/">Steam</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/playstation-4/">PlayStation 4</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/documentary/">documentary</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/xbox-one/">Xbox One</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/lincoln-hall/">lincoln hall</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/art-house-cinema/">Art House cinema</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/today/">Today</a><span class="sep">/</span> <a href="https://thirdcoastreview.com/tag/gene-siskel-film-center/">Gene Siskel Film Center</a></li>
		</ul>
		<a href="http://wordpress.org/" title="A Semantic Personal Publishing Platform" rel="generator">Proudly powered by WordPress</a>
		<span class="sep"> | </span>
		 Developed by <a href="https://utopiandesigns.co/" target="_blank">Utopian Designs</a> <span class="sep"> | </span> Copyright 2016-2018 - Nancy S Bishop, editor and publisher, Third Coast Review. <span class="sep"> | </span> <a href="/wp-login.php/">Login</a>
	</section>
</footer>


<script>
jQuery(document).ready(function(){
  jQuery(".entry a").attr("target","_blank");
});
</script>
	
			<style type="text/css">
				.ssp-wave wave wave{
					background: #28c0e1 !important;
				}
			</style>
		<div id="wdsi-slide_in" style="display:none;" class="wdsi-slide  wdsi-slide-right wdsi-slide-minimal wdsi-slide-minimal-light wdsi-slide-minimal-blue" data-slidein-start="40%"  data-slidein-end="100%" data-slidein-after="0s" data-slidein-timeout="1m" data-slidein-id="6219" >

	<div class="wdsi-slide-wrap" style="width:400px;" >
		<div class="wdsi-slide-control">
	<div class="wdsi-slide-share wdsi-clearfix">
			</div>
	<div class="wdsi-slide-close"><a href="#">Close</a></div>
</div>		<div class="wdsi-slide-content">
			<h1 class="wdsi-slide-title wdsi-slide-bold wdsi-slide-italic">Plan Your Life with 3CR Highlights</h1>
			<p>Join Our Newsletter today!</p>
<form id="wdsi-mailchimp-5dbd45dda5c3619ef0fcfe5219a29403" class="wdsi-mailchimp-root wdsi-clearfix"><input type="hidden" class="wdsi-mailchimp-post_id" value="6219" /><label for="wdsi-mailchimp-5dbd45dda5c3619ef0fcfe5219a29403-email" class="wdsi-mailchimp-label">Email:</label><input type="text" id="wdsi-mailchimp-5dbd45dda5c3619ef0fcfe5219a29403-email" class="wdsi-mailchimp-email" placeholder="Your Email" /><button class="wdsi-mailchimp-subscribe" type="button">Subscribe</button><div class="wdsi-mailchimp-result"></div></form>
<script>
(function ($) {

function mailchimp_subscribe (root) {
	var $email = root.find(".wdsi-mailchimp-email"),
		$post_id = root.find(".wdsi-mailchimp-post_id"),
		$result = root.find(".wdsi-mailchimp-result")
	;
	if (!$email.length || !$email.val()) return false;
	$.post("https://thirdcoastreview.com/wp-admin/admin-ajax.php", {
		"action": "wdsi_mailchimp_subscribe",
		'post_id': $post_id.val(),
		"email": $email.val()
	}, function (data) {
		var is_error = data && data.is_error && parseInt(data.is_error, 10),
			msg = (data && data.message ? data.message : "Error"),
			error_class = 'wdsi-mailchimp_error',
			success_class = 'wdsi-mailchimp_success',
			wrapper = (is_error ? error_class : success_class)
		;
		$result
			.removeClass(error_class).removeClass(success_class)
			.addClass(wrapper)
			.html(msg)
		;
	}, 'json');
	return false;
}

$(function () {
$(".wdsi-mailchimp-subscribe").click(function () {
	mailchimp_subscribe($(this).parents(".wdsi-mailchimp-root"));
	return false;
});
});
})(jQuery);
</script>		</div>
			</div>
</div>	<div style="display:none">
	</div>
<script type="text/javascript">
jQuery(document).ready(function ($) {

    $(".eventList").find("a").addClass("anchor");

  $('.eventList li').each( function(i,v)
  {
if($(this).find('time').attr('datetime').substring(0,10) == $(this).next().find('time').attr('datetime').substring(0,10))
            {
              $(this).next().children('.wpmudevevents-date:first').hide();
		$(this).next().addClass('not-first');
            } else {

}
  })
});
</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/thirdcoastreview.com\/2020\/05\/18\/review-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite\/":71691};
	</script>
<script>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</script><script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/js/wpmu-ui.3.min.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/popover/js/public.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/thirdcoastreview.com\/wp-admin\/admin-ajax.php","nonce":"c2427e9d5c","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/thirdcoastreview.com\/wp-login.php?redirect_to=https%3A%2F%2Fthirdcoastreview.com%2F2020%2F05%2F18%2Freview-action-packed-fury-unleashed-is-a-great-rogue-lite-with-an-emphasis-on-the-lite%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://thirdcoastreview.com/wp-content/plugins/jetpack/_inc/build/widgets/milestone/milestone.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202021.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.4.3',blog:'104405576',post:'71691',tz:'-5',srv:'thirdcoastreview.com'} ]);
	_stq.push([ 'clickTrackerInit', '104405576', '71691' ]);
</script>

</body>
</html>